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BioNumerics R© uses following third-party software tools and libraries:
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Chapter 1

Starting and setting up BioNumerics

1.1 Introduction

This guide is designed as a tutorial for the Geographical mapping plugin of BioNumerics. This plugin
allows you to plot geographical locations on a map, using the Google Maps API. Locations should be
provided either as addresses or as longitude and latitude coordinates, stored as entry information in the
BioNumerics database.

In addition, superimposed graphs allow the visualization of additional information stored in entry info fields
(categories), character values or even dendrograms on top of geographical maps.

1.2 Startup program

When BioNumerics is launched from the Windows start panel or when the BioNumerics shortcut ( ) on
your computer’s desktop is double-clicked, the Startup program is run. This program shows the BioNu-
merics Startup window (see Figure 1.1).

A new BioNumerics database is created from the Startup program by pressing the button.

An existing database is opened in BioNumerics with or by simply double-clicking on a database
name in the list.

1.3 Installing the Geographical mapping plugin

If a database is opened for the first time, the Plugins dialog box will appear by default (see Figure 1.2).

If the database has already been opened previously, the Plugins dialog box can be called from the Main
window by selecting File > Install / remove plugins... ( ).

When a particular plugin is selected from the list of plugins, a short description appears in the right panel.

A selected plugin can be installed with the <Activate> button. The software will ask for confirmation
before installation. Some plugins depend on functionality offered by specific BioNumerics modules. If a
required module is missing, the plugin cannot be installed and an error message will be generated.

Once a plugin is installed, it is marked with a green V-sign. It can be removed again with the <Deactivate>
button.
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Figure 1.1: The BioNumerics Startup window.

Figure 1.2: The Plugins dialog box.

If the selected plugin is documented, pressing <Show Manual> will open its manual in the Help window.

3.1 Select the Geographical mapping plugin from the list in the Utilities tab and press the <Activate> button.
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3.2 The program will ask to confirm the installation of the plugin. Press <OK> to confirm the installation.

3.3 Press <OK> to continue with the installation of the plugin.

3.4 Close and reopen the database with administrator privileges to activate the features of the Geographical
mapping plugin.

The plugin provides two additional commands: Analysis > Geo chart... ( ) in the Main window (see
Figure 1.3) and Statistics > Geo chart... ( ) in the Comparison window.

Figure 1.3: Geo chart menu in the Main window.
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Chapter 2

Geographical data

2.1 Geocoding

The Geographical mapping plugin in BioNumerics uses the Google Geocoding API from the Google
Maps API Web Service, an HTTP interface to the Google service providing geographic data (https://
developers.google.com/maps/documentation/geocoding/, https://developers.google.com/
maps/documentation/webservices/). Geocoding is the process of converting addresses (like ”Keistraat
120, 9830 Sint-Martens-Latem, Belgium”) into geographic coordinates (like latitude 50.993394 and longi-
tude 3.62993), which can be use as place markers or positions on the map.

Using the Geographical mapping plugin, both latitude - longitude information as well as full address in-
formation, or both, can be used to plot data on the map. The Google Geocoding results provided by the
web service are saved to the database and fully integrated in the BioNumerics user interface. This way, it
becomes easy to obtain the envisaged plots, displaying a selection of specific database information plotted
on the geographical map.

2.2 Database entries panel

The BioNumerics Main window in the default configuration consists of a menu, a toolbar for quick access
to the most important functions, a status bar, and various analysis panels Figure 2.1. The Database entries
panel lists all the available entries in the database, with their information fields and their unique keys. With
the Geographical mapping plugin, information present in the information fields in the Database entries
panel can be mapped.

2.3 Information fields

The DemoBase Connected either can be downloaded directly from the BioNumerics Startup window or
restored from the back-up file available on our website:

• To download the database directly from the BioNumerics Startup window, click the Download ex-
ample databases link, located in the lower right corner of the BioNumerics Startup window. Select
DemoBase Connected from the list and select Database > Download.

• To restore the database from the back-up file, first download the file DemoBase Connected.bnbk

from http://www.applied-maths.com/download/sample-data, under ’DemoBase Connected’.

https://developers.google.com/maps/documentation/geocoding/
https://developers.google.com/maps/documentation/geocoding/
https://developers.google.com/maps/documentation/webservices/
https://developers.google.com/maps/documentation/webservices/
http://www.applied-maths.com/download/sample-data
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Figure 2.1: The BioNumerics Main window.

In the BioNumerics Startup window, press the button, select Restore database, browse for the
downloaded file and select Create copy. Specify a name and click <OK>.

3.1 Open the demonstration database DemoBase Connected and install the Geographical mapping plugin
(see 1.3).

3.2 In the BioNumerics Main window select Edit > Information fields > Add information field.... This
will open the Create new entry information field dialog box.

3.3 Enter “Country” in the dialog box that pops up, leave all other settings default and press <OK>.

The information field Country is added to the list of database fields.

3.4 Double-click on the entry with key G@Gel07@002. The Entry window appears.

3.5 Click on the box next to the information field Country. The information field is highlighted (see Figure
2.2).

3.6 Enter e.g. “France” and press the Enter key or select <OK> to close the Entry window.

The information is now stored in the database. Alternatively to using the Entry window, information in the
information fields in the database can be edited directly by clicking twice with a short interval (not double
clicking) on an information field in the database. The information will appear highlighted and can be edited.

3.7 Click twice on the information field Country of the entry with key G@Gel07@003.

3.8 Enter “Spain” in the highlighted information field and press Enter. The information is stored in the
database.

2.4 Importing geo data

The general BioNumerics import functionality can be used to import information from text files (tab, comma
or semicolon separated), MS Excel or from other databases (e.g. MS Access) via an ODBC link.
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Figure 2.2: The Entry window.

As an example, we will import geographical data from a tab-delimited text file. The example data file
Geo information.txt can be downloaded as a ZIP archive from the Applied Maths website (http://
www.applied-maths.com/download/sample-data, click on ”Geo data file”).

4.1 In the Main window, select File > Import... ( , Ctrl+I) to open the Import dialog box.

4.2 Select Entry information data > Import fields (text file) and press <Import>.

The Input wizard page pops up (Figure 2.3), allowing you to browse to the (unzipped) input text file.

Figure 2.3: Importing geographical data from a text file.

4.3 Browse for the Geo information.txt file and press <Next> to continue.

http://www.applied-maths.com/download/sample-data
http://www.applied-maths.com/download/sample-data
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4.4 The Import rules dialog box lists the columns present in the selected text file as Source, their linked
Source type and the Destination component they are associated with (currently all set to <None>).

4.5 Select Key from the list. Select <Edit destination. . .> and select Key as the BioNumerics corresponding
field. The import rules are now updated accordingly (see Figure 2.4).

Figure 2.4: The Import rules dialog box.

4.6 Next, select Country from the list and edit this destination by selecting <Edit destination. . .> or double-
clicking the Destination type on the Country row. Associate the information in this column with the
BioNumerics entry information field Country and confirm by <OK>.

4.7 Select all the other rows (Origin, Longitude, Latitude, Comment and Date) and edit their destination as
a new entry information field by selecting Entry information field. Confirm the suggested information
field names and the creation of these fields in the database. This will update the Import rules dialog box
(see Figure 2.5). Note that not all these fields are required to use the plugin. The plugin can function
perfectly with just one e.g. “Origin” field.

4.8 Press <Next> to proceed with the import. This will display the Import links dialog box. In this dialog,
specify that the Key information should be used as linked information field.

4.9 Press <Finish>.

This completes the creation of the import template and pops up a dialog asking for the template name (see
Figure 2.6).

4.10 Enter a name (e.g. “Import geo information demobase”) and optionally, also a description for the import
template (e.g. “This template imports geographical information from text file, links the Key information
and imports longitude, latitude information”) and press <OK> to close the Import template information
dialog box.

The import template is now listed in the Import template wizard page. When selecting the template, the
description is displayed at the right of the template list.

4.11 Press <Next> to proceed with the import.
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Figure 2.5: The Import rules dialog box with all import rules added.

Figure 2.6: The Import template information dialog box.

From the database links that are updated, you can verify that the geographical information will be updated
for 47 entries.

4.12 Press <Finish> to complete the import and update the database.

For all entries, except the standards, the database field information for the columns ’Country’, ’Origin’,
’Longitude’, ’Latitude’, ’Comment’ and ’Date’ is now updated (see Figure 2.7).

Both the imported ’Longitude’ and ’Latitude’ columns contain numeric information. To allow geographical
binning on this information, the field type of these columns should be updated.

4.13 Right-click on the entry field header ’Longitude’, and select Field properties . . . from the pop-up menu
that appears. This opens the Database field properties dialog box. Change the Content type to “Number”
and press <OK> to close the dialog.

4.14 Repeat the instructions above to change the content type of the ’Latitude’ field to “Number”.

Geographical binning can also be applied to time information i.e. date information. To use this feature, the
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Figure 2.7: Imported information fields containing geographical data.

field properties for the ’Date’ field should be changed.

4.15 Right-click the entry field header ’Date’, select Field properties . . . from the pop-up menu, and change
the Content type in the the Database field properties dialog box to “Date”. Press <OK> to close the
dialog.

2.5 Composing addresses from entry fields

The Geographical mapping plugin uses location information (i.e. addresses) stored in a single entry infor-
mation field to submit to the Google Maps API (see 3.2). However, location information will typically be
split up over several fields in a normalized database (i.e. Street, City, Country, etc. filled out in separate
columns), as this greatly facilitates searching, filtering and sorting on these address aspects. To get round
this, we can use a calculated field to compose a full address from several address aspects, stored in separate
entry information fields. As calculated fields are dynamically calculated, this avoids duplicating the address
information in the database.

Here, we will show how to compose location information from the ’Origin’ and ’Country’ fields in the
DemoBase Connected demonstration database.

5.1 In the Main window, select Edit > Information fields > Add information field... or highlight the Entry
fields panel and select Edit > Create new object... ( ).

5.2 In the Create new entry information field dialog box that pops up, enter e.g. “Address” as Name of the
new information field.
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5.3 Check the option Calculate field content from other fields and press the <Edit> button to display the
Calculated database field settings dialog box.

5.4 Press <Add information field...>.

5.5 In the Add information field dialog box, select the Origin field from the list and press <OK>.

Back in the Calculated database field settings dialog box, [ORIGIN] is now displayed as part of the ”for-
mula” to calculate the field content.

5.6 Press <Add fixed text...>.

5.7 In the Add fixed text dialog box, enter “, ” (i.e. a comma, followed by a space) and press <OK>.

5.8 Press <Add information field...> again.

5.9 In the Add information field dialog box, select the Country field from the list and press <OK>.

The Calculated database field settings dialog box now looks like in Figure 2.8.

Figure 2.8: The Calculated database field settings dialog box, showing the calculated field
settings for the Address field.

5.10 Press <OK> to accept the calculated field settings and <OK> once more in the Create new entry infor-
mation field dialog box.

The new calculated field ’Address’ now contains the information from the ’Origin’ and the ’Country’ fields,
separated with a comma and a space (e.g. ”Bordeaux, France”).

The text address field in the database can also contain street names, house numbers, or names of
hospitals, monuments, etc..

2.6 Latitude and longitude

Instead of providing an address and using forward geocoding to find the corresponding coordinates (and plot
these on a geographical map), a location can also be specified directly using coordinates. This requires a
latitude (North-South position) and longitude (East-West position) for each location. The expected format
for latitudes and longitudes is decimal degrees, with a point as decimal separator.

The example geographical information that was imported (see 2.4) contains latitude and longitude data for
most, but not all, entries in DemoBase Connected.
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Plotting data on geographical maps

3.1 Deciding which entries to plot

There are two ways to plot entries on a geographical map (see also 1.3):

• Starting from the selected entries in the Main window (see below for a brief description).

• Starting from the Comparison window. If no entry selection is present, all entries in the comparison
will be used. In case a selection is present, only the selected entries in the comparison will be plotted.
Character values and dendrograms can only be plotted on geographical maps when starting from the
Comparison window.

Hence, before we can plot any entries from the Main window, we need to make a selection in the database.

1.1 Select a single entry in the Database entries panel by holding the Ctrl-key and left-clicking on the entry.
Alternatively, use the space bar to select a highlighted entry or click the ballot box next to the entry.

Selected entries are marked by a checked ballot box ( ) and can be unselected in the same way.

1.2 In order to select a group of entries, hold the Shift-key and click on another entry.

A group of entries can be unselected the same way.

1.3 All entries can be selected at once with Edit > Select all (Ctrl+A).

1.4 Clear all selected entries with Database > Entries > Unselect all entries (all levels) ( , F4).

3.2 Plotting locations only

In the following tutorial, it is described to plot locations (stored in entry information fields) on a geographical
map, without additional information. In this case, the locations will appear as dots on the map.

As an example, we could plot all entries in DemoBase Connected for which location information is avail-
able.

2.1 Select all entries, except for the standards, in the Database entries panel and select Analysis > Geo
chart... ( ).

The Basic info wizard page pops up (see Figure 3.1).

This wizard page lists the different graph types that can be used and queries for the entry fields which contain
the geographical information.
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Figure 3.1: The Basic info wizard page.

The Graph type can be specified. The following types are available:

• Pies: The data is plotted in circular pie charts, with the size of the pies proportional to the number of
entries per location. Locations, relative number of entries per location (via the pie size) and categories
(using colors) can be indicated with pies.

• Frequency bars: The data is plotted in vertical bar graphs. The height of the bars will be proportional
to the number of entries that have an identical location and category. Similar to pies, frequency bars
can indicate locations, relative number of entries per location (via the bar height) and categories (using
colors).

• Stacked bars: The data is plotted in vertical stacked bar graphs, with differently colored categories
stacked on top of one another per bar. In addition, the data can be binned using text categories,
numbers or dates. Each bin is hereby represented by a single bar in the stacked bar graph. Note
that character values (character type experiments and composite data sets) can only be plotted via the
Stacked bar graphs option. A stacked bar graphs can indicate location and two different categories
or a location, a category and a summarized character value per category.

• Dots: The data is plotted as discrete data points. Dots can indicate locations only (no extra informa-
tion, except for the selection state).

• Dendrogram: A dendrogram, i.e. the result of a cluster analysis, is superimposed on the geographical
map.

Under Location data the data used for mapping can be specified:

• Text address description (one entry field): When checking this option, entries will be mapped based
on the location information present in one of the database information fields. See 2.5 on how to
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compose full addresses using calculated fields. In the next step of the wizard, the information field(s)
containing the location information can be specified as Full address field (see Figure 3.2).

• Latitude and longitude (two entry fields): With this option, entries can be plotted based on latitude
and longitude information, present in two separate information fields in the database. When check-
ing this option, the information fields where the latitude and longitude information is stored in the
database should be specified as Latitude field and Longitude field, respectively.

• The results of all the entry locations can be combined according to the Location agglomeration.
Possible examples of location agglomerations are: “Sublocality”, “Locality”, “Administrative level
2”, “Administrative level 1” or “Country”. A last option is “Use full address”. The latter option
implies that only those locations returning exact the same coordinates from Google Maps, will be
combined while plotting the data.

When a Text address description and Latitude and longitude are provided, the latter are used
preferentially. The text address descriptions are only used if no coordinate information is avail-
able.

Since we only want to plot locations (no additional information), we will use dots in this tutorial.

2.2 Check Dots as Graph type.

In the DemoBase Connected database, coordinate information is available for most, but not for all entries.
We will therefore use both the address and the coordinates as location data.

2.3 Under Location data, check both Text address description (one entry field) and Latitude and longitude
(two entry fields).

2.4 Make sure that “Use full address” is selected for Agglomeration level and press <Next> to proceed.

Figure 3.2: The Location field wizard page.
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When using a Text address description as location data for the entries, the Full address field can be entered
from this wizard page (see Figure 3.2). The Full address field refers to the database information field that
contains the address. A drop-down list shows all available entry information fields.

2.5 Select the “Address” calculated field that we created earlier (see 2.5) from the list of database fields.

This information is needed for the mapping of entries that do not have coordinates in the database (no infor-
mation is present in the ’Longitude’ and ’Latitude’ information fields for entries with key G@Gel07@015,
G@Gel08@012 and G@Gel09@011).

2.6 Press <Next> to proceed to the Latitude & longitude field wizard page (see Figure 3.3).

Figure 3.3: The Latitude & longitude field wizard page.

The Latitude & longitude field wizard page is only displayed when using latitude and longitude as location
data for the entries in the Basic info wizard page. On this page, the database information fields that contain
the latitude (Latitude Field) and the longitude (Longitude Field) can be selected from the drop-down lists
containing all entry information fields.

In case latitude and/or longitude information is missing for one or more entries, a warning mes-
sage will appear in the Latitude & longitude field wizard page.

2.7 Select the database fields “Latitude” and “Longitude” as Latitude Field Name and Longitude Field
Name, respectively.

2.8 Press <Next> to continue to the Geolocation hint and language wizard page (see Figure 3.4).

In the Geolocation hint and language wizard page, a Location hint can be specified. This hint will be used
to narrow down the search on the geo server. If all the addresses are located e.g. within the same continent
or country, you can enter this information as Location hint.

The Language setting in the Geolocation hint and language wizard page refers to the language of the place
names that the Google Maps API returns. Altering this settings has effect on the geocoding results, and thus
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Figure 3.4: The Geolocation hint and language wizard page.

on the unresolved locations that are returned.

2.9 Enter “Europe” as location hint, select “English” as Address language and press <Finish> to open the
map in the Geo window (see Figure 3.5).

To illustrate that coordinates were used, proceed as follows:

2.10 Zoom in on the city Valencia by double-clicking the map near Valencia several times.

Because two different sets of coordinates in Valencia are stored in the information fields ’Latitude’ and
’Longitude’ in the database, two dots appear in the city Valencia (see Figure 3.6):

Detailed information on available functionality in the Geo window can be found in 4.

3.3 Plotting locations and info from a single field

Choosing a graph different from dots in the Geo chart settings wizard provides the option to visualize extra
information (in addition to location) on a geographical map. This includes the number of entries found per
location and optionally categories that are stored in a single entry information field.

For example, say that we want to plot the genera that are found on each of the text addresses that are stored
in DemoBase connected.

3.1 Select all entries, except for the standards, in the Database entries panel and select Analysis > Geo
chart... ( ).

In case you opened the Geo window already (e.g. because you followed the previous tutorial, see 3.2), the
Previous settings wizard page will appear (see Figure 3.7).

When closing the Geo window, the most recently used mapping settings are stored in the database. This
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Figure 3.5: The Geo window, displaying locations as simple dots.

Figure 3.6: Coordinate-based locations can distinguish different places in the same city.

allows you to create a similar geographical map e.g. on another set of selected database entries, without
running the wizard again.

The Previous settings wizard page displays a summary of the previously used mapping settings.

At this point, you have the option to Reuse the previous settings. With this option checked, pressing
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Figure 3.7: The Previous settings wizard page.

<Next> will result in the creation of a geographical map based on the settings that are listed in the dialog.

If you leave Reuse the previous settings unchecked, pressing <Next> will initiate the different pages in the
geographical mapping wizard one by one, and allows to change the individual mapping settings to create
another customized geographical map.

3.2 Leave the option Reuse the previous settings unchecked and press <Next>.

3.3 In the Basic info wizard page, check either Pies or Frequency bars as Graph type.

3.4 Uncheck Latitude and longitude (two entry fields) to use only text addresses and press <Next>.

3.5 In the Location field wizard page, leave “Address” selected for Full address field and press <Next>.

This action will display the Color field wizard page (see Figure 3.8).

When starting from the Main window, only database fields can be selected from the Color field wizard page
to use as color category in the chart (see Figure 3.8).

When “<No colors>” is selected from the Categories field drop-down list, no category colors will be
displayed in the graphs. This option can be used to draw graphs (i.e. bars or circles) of the same color, that
are scaled proportionally to the number of entries per location.

When selecting an information field as Categories field from the drop-down list with none of the options
checked, each unique content for the selected information field will be assigned to a different color, and will
be plotted in this color in the charts on the map.

The option Restrict to field states only becomes available when information field states (see the Refer-
ence manual, Chapter Database entries) are present for the highlighted information field. With this option
checked, the graph will be limited to those entries having their field state defined in the Database field
properties dialog box.
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Figure 3.8: The Color field wizard page, when the Geo chart settings wizard was started
from the Main window.

When Sort categories per pie, merging the smaller ones is checked, each pie chart will start with the
largest category on that location, followed by the second largest, etc.. All categories that are below the
Merge categories below threshold will be merged into a single ”miscellaneous” category. With the Sort
categories per pie, merging the smaller ones option unchecked, the same category order is used for all pie
charts and smaller categories are not merged.

3.6 Select “Genus” as Categories field, leave the other options unchecked and press <Next> to proceed.

3.7 In the Geolocation hint and language wizard page, enter “Europe” as location hint, select “English” as
Address language and press <Finish> to open the map in the Geo window (see Figure 3.9).

Detailed information on available functionality in the Geo window can be found in 4.

3.4 Plotting locations and info from two fields

Using a stacked bar graph, categorical information from two entry information fields can be visualized.

For example, say that we want to plot the genera that are found on each of the text addresses and break these
down per year of isolation (the latter information is stored in the ’Date’ field).

4.1 Select all entries, except for the standards, in the Database entries panel and select Analysis > Geo
chart... ( ).

4.2 In the Previous settings wizard page, leave the option Reuse the previous settings unchecked and press
<Next>.

4.3 In the Basic info wizard page, check Stacked bars as Graph type, use only text addresses and press
<Next>.
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Figure 3.9: The Geo window, displaying pie charts with categories defined based on the
’Genus’ information field.

4.4 In the Location field wizard page, leave “Address” selected for Full address field and press <Next>.

4.5 In the Color field wizard page, select “Genus” from the Categories field and press <Next>.

This action will display the Binning field wizard page (see Figure 3.10).

The Binning field wizard page is only displayed when stacked bar graphs were indicated as graph type and
when categories are created based on an information field or from comparison groups (available when the
Geo chart settings wizard was started from the Comparison window). When both conditions are fulfilled, a
Binning field can be selected from the corresponding drop-down list.

Any of the user-created information fields (standard properties such as ’Key’ and ’Modified date’ are not
available) can be selected as Binning field. The field content will be used to separate the data from the
different categories. The type of field (Text, Number or Date) of the selected field will be indicated. A
warning will appear in case the field is empty for some of the entries.

When a Date field is selected, an additional Date grouping span drop-down list is displayed. This allows
binning of the data according to “Year”, “Quarter”, “Month”, “Week” or “Day”.

When a Number field is selected, the Number of bins can be defined and the bins are created linearly.

When selecting “<No binning>” from the Binning field drop-down list, the bars will be created from the
original category data, without binning.

4.6 Select “Date” as Binning field and use “Year” as as Date grouping span. Next, press <Next>.

4.7 In the Geolocation hint and language wizard page, enter “Europe” as location hint, select “English” as
Address language and press <Finish> to open the map in the Geo window (see Figure 3.11).
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Figure 3.10: The Binning field wizard page.

Detailed information on available functionality in the Geo window can be found in 4.

3.5 Plotting locations and character data

In order to use experimental information (character data and composite data sets) in graphs on a geographical
map, one needs to start from the Comparison window.

For example, say that we want to create bar graphs with the average composition of the major fatty acids
per location.

First, we will create a comparison that contains all entries with address information:

5.1 In the Database entries panel of the Main window, select all entries except for the standards.

5.2 Highlight the Comparisons panel in the Main window and select Edit > Create new object... ( ).

The Comparison window now opens with the selected entries.

The number of bars in a stacked bar graph on a geographical map is limited to 20. Since the FAME
experiment type contains many more characters, we will make a character selection with the major fatty
acids:

5.3 In the Experiments panel, click on the eye icon ( ) next to FAME to visualize the data in the Experiment
data panel.

5.4 In the header of the Experiment data panel, Ctrl+click on 14:0 to select this character.

5.5 Repeat Instruction 5.4 for 16:0, Sum in Feature 7, Sum in Feature 3 and Sum in Feature 4.
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Figure 3.11: The Geo window, displaying stacked bar graphs with categories defined based
on the ’Genus’ information field. The data is binned based on the ’Date’ information provided
for each sample, creating bins for each year.

If the same set of character is used more than once, it is recommended to create a character view
for it (see the Reference manual, Chapter Setting up character type experiments).

Now we will plot the information on a geographical map:

5.6 Select Statistics > Geo chart... ( ).

5.7 In the Previous settings wizard page, leave the option Reuse the previous settings unchecked and press
<Next>.

5.8 In the Basic info wizard page, check Stacked bars as Graph type, use only text addresses and press
<Next>.

5.9 In the Location field wizard page, leave “Address” selected for Full address field and press <Next>.

This action will display the Color field wizard page (see Figure 3.12).

When the Geo chart settings wizard is started from the Comparison window, additional options are available
to use as a color category in the chart:

• Comparison groups: User-defined groups in the Comparison window, see the Reference manual,
Chapter General comparison functions.

• Character data: Any view (default or user-defined) on character type experiments that contains data.
For more information on character views, see the Reference manual, Chapter Setting up character
type experiments.
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Figure 3.12: The Color field wizard page, when the Geo chart settings wizard was started
from the Comparison window. A character view is selected as Categories field.

• Composite data sets: Any composite data set (see the Reference manual, Part Composite data sets)
that contains data.

When a character view or composite data set is selected as Categories field, the Character data handling
should be specified. Following options are available:

• Treat as categorical: Each character value is considered as an individual state. This is useful for e.g.
MLVA, MLST or SNP data sets that are multi-state or categorical by design, but should not be used
for quantitative data.

• Use character mapping: Uses the character mapping (see the Reference manual, Chapter Setting up
character type experiments) instead of the character values. This option is only available if a character
mapping was defined in the Character type window.

• Summarize: take average: Calculates for each character the average value per location.

• Summarize: take median: Calculates for each character the median value per location.

• Summarize: take sum: Calculates for each character the summed values per location.

Hence, the first two options treat the data as categorical and produce stacked bar graphs with the colors
indicating the fraction of entries that belong to each category. The three latter options generate quantitative
values, which will result in the creation of regular bar graphs (i.e., with the height of the bars proportional
to the value).

5.10 Select “<FAME – Selected Characters>” as Categories field, check Summarize: take average and press
<Next> to proceed.
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5.11 In the Geolocation hint and language wizard page, enter “Europe” as location hint, select “English” as
Address language and press <Finish> to open the map in the Geo window (see Figure 3.13).

Figure 3.13: The Geo window, displaying bar graphs with average relative occurrences of
the major fatty acids.

Detailed information on available functionality in the Geo window can be found in 4.

3.6 Plotting locations and dendrograms

Another type of graph that can be displayed on a geographical map is a dendrogram. In contrast to other
graphs, which visualize additional data per location, a dendrogram connects the locations and indicates
similarity between the entries on different locations. Plotting a dendrogram is only possible from the Com-
parison window when at least one cluster analysis is calculated.

Since the combination of similarity and geographical information quickly becomes very complicated, it is
best to start with a limited number of entries:

6.1 Select the entries with strain number 42818, 42855, 52414, 52418, and 52420.

6.2 Highlight the Comparisons panel in the Main window and select Edit > Create new object... ( ).

The Comparison window now opens with the five selected entries. First, we will calculate a dendrogram:

6.3 Click on RFLP1 in the Experiments panel to make this the active experiment type.

6.4 Select Clustering > Calculate > Cluster analysis (similarity matrix)....

6.5 In the Comparison settings wizard that appears, leave all settings to their defaults, press <Next> and
<Finish>.
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A dendrogram is calculated and appears in the Dendrogram panel. Next, we will plot this dendrogram on a
geographical map:

6.6 Select Statistics > Geo chart... ( ).

6.7 In the Previous settings wizard page, leave the option Reuse the previous settings unchecked and press
<Next>.

6.8 In the Basic info wizard page, check Dendrogram as Graph type, use only text addresses and press
<Next>.

6.9 In the Location field wizard page, leave “Address” selected for Full address field and press <Next>.

6.10 In the Geolocation hint and language wizard page, enter “Europe” as location hint, select “English” as
Address language and press <Finish> to open the map in the Geo window (see Figure 3.14).

Figure 3.14: The Geo window, displaying a dendrogram.

Locations are indicated on the map with colored dots, identical to the ones used in 3.2. Branch nodes in
the dendrogram are visualized with smaller, white dots. The dendrogram root is shown with a black dot.
When hovering over a location, the path to the dendrogram root is shown in solid black. Likewise, when
hovering over a branch node with the mouse, the path to the dendrogram root is drawn in solid black and
the corresponding branch is displayed in solid red.

To allow the display of connection lines between entries in case multiple entries have the same
location, these entries are spread out in a circle around their actual location.

Detailed information on available functionality in the Geo window can be found in 4.



Chapter 4

Functionality in the Geo window

4.1 The Geo window

The Geo window displays the geographical map with graphs indicating locations and optional additional
information. It also provides feedback on location, category, binning information used and entry selection.
The window consists of five different panels:

• The Map panel displays the geographical map with dots, pie charts, bar graphs or dendrogram plotted
onto the map. Different map views become available by pressing the buttons in the top left of the Map
panel: the map without town information (<No towns>), the map with town information (<Only
towns>), the map displaying all geographical location information (<Map>) and a satellite view
(<Satellite>).

• The Locations panel indicates which locations are plotted onto the map and on which location infor-
mation this was based. Locations preceded by a ’@’ refer to longitude-latitude information, while
e.g. text like ”Lyon, France” indicate that a text address was used to retrieve the location information.
Further, the number of entries per location is indicated and the geo mapping state (”Resolved” or
”Unresolved”; see 4.2 for more information). For text addresses, the used location as derived from
the geo mapping is also indicated in this panel.

• The Binning panel provides an overview of the different binning categories that were created based
on the specified binning field. For each selected location in the Map panel, the number of entries
enclosed in this bin is updated in the ’Count’ column.

• The Categories panel lists all the different categories that are plotted on the geographical map for
the current location and bin. Next to the categories, the corresponding plot color and the number of
entities enclosed in this specific category are displayed.

• The Entries panel lists the entries from selected locations, with all entry information fields.

To move the map in the Map panel, click on the map and drag it in the desired direction.

Use View > Zoom to fit ( ) to set the position and zoom level of the map so that all graphs fit in the Map
panel.

Zoom in or out on the center of the map by selecting View > Zoom in ( ) or View > Zoom out ( ),
respectively. Use the scroll wheel of the mouse to zoom in and out on the position of the mouse pointer.
Double-clicking the left mouse button zooms in on the position of the mouse pointer; double-clicking the
right mouse button zooms out.

To enlarge or shrink bar graphs, stacked bar graphs or pie charts on the map, use View > Scale up ( ) or
View > Scale down ( ), respectively.
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Hovering over a graph will display a ”tool tip” with additional information.

With Edit > Modify settings ( ), the current locations can be plot on the geographical map using other
settings. This action calls the Basic info wizard page again, as described in 3.2.

4.2 Resolving undefined geographical positions

When plotting information based on text addresses, it is possible that more than one location with the same
name is retrieved or that the address could not be found by the Google Geocoding web service.

With the example data set, if entries present in the DemoBase Connected database are plotted based on
their address description, multiple locations are found for ”Valencia, Spain”, as indicated by the yellow row
in the Locations panel (see Figure 4.1). One location is the preferred location and is used for plotting.

Figure 4.1: Unresolved locations are indicated in yellow in the Locations panel of the Geo
window.

To view the unresolved positions for a location, click on the location in the Locations panel and select Edit
> Edit geocoding ( ), or simply double-click on the location. This action will display the Results dialog
box (see Figure 4.2).

This dialog box lists all alternatives which where found for the provided location. In the background, the
geographical map is updated with the locations for the alternatives positions. The location that is highlighted
in blue in the Results dialog box will be selected (shown as an orange dot or halo) on the geographical map,
to help deciding on the location.

To select a different location, click on a position from the list to highlight it and press <Save>. This action
saves the updated geo information links to the database, removes the yellow highlight from the Locations
panel, and changes the State of the location from ”Unresolved” to ”Resolved”. Once the locations have been
resolved and saved to the geo cache, the next time the geo analysis is launched, this updated information
will be taken into account and the locations will be listed as ”Resolved”.

Any location, but especially locations that are listed as ’not found’, can be modified or updated in the
Search address text field of the Results dialog box. A new geo search with the updated information is then
launched by pressing the <Submit> button. The updated results will be displayed in the Selected location
list. Highlight any of these results and press <Save> to save the selected location to the Locations panel.

By using Edit > Clear cache ( ), the geo information of the currently highlighted location(s) in the Lo-
cations panel will be deleted from the cache. When using this command, you will also delete the saved
information from the unresolved locations. When performing a new geographical analysis, the locations
will appear again as unresolved. This functionality can be used e.g. if you want French instead of English
location names: first, modify the address language and then, clear the cache for all locations and resubmit
the location searches.

Within the Locations panel, the information present in a selected column can be sorted by using Edit > Sort
( ). This can be particularly useful e.g. when searching for all unresolved location states.

A selected location can be removed from the map by selecting Edit > Remove ( ). This action immediately
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Figure 4.2: The Results dialog box, showing all alternatives for the unresolved location
”Valencia, Spain”. In the background, part of the geographical map is displayed with the
highlighted location selected in orange.

updates the map. There is no undo functionality for this action. To restart the analysis with all available
information, close the window by selecting File > Exit (Alt+F4), and choose Analysis > Geo chart... ( )
to recreate the original map.

4.3 Selecting locations and entries

Selections of locations and entries provide an interactive way to link geographical information with other
analyses in BioNumerics. For example, one could select the entries from nearby locations and check how
similar these entries are by observing the position of the selected entries in a cluster analysis or PCA.
Conversely, one could select a set of highly similar entries from a brach in a dendrogram and then visualize
their geographical spread on a map.

Locations in the Map panel can be selected or unselected with Ctrl+click. Selected locations are indicated
as orange dots (for dots), with an orange halo (for pie charts) or underlined in orange (for bar graphs). In the
Locations panel, the corresponding rows are highlighted. Locations can also be selected from the Locations
panel using Ctrl+click or Shift+click (for complete ranges) and the Map panel is updated automatically.

Another very flexible method to select locations in the Map panel is via the lasso tool: select Selection >
Lasso select ( ) and drag the lasso with the mouse around the locations to be selected. This action adds
the locations ”captured” by the lasso to the existing location selection.

A selection of locations can be inverted with Selection > Invert selection ( ): The selected locations will
be unselected and the unselected locations will now be selected.

To clear the locations selection, i.e. to unselect all locations, use Selection > Clear selection ( ).

It is important to realize that a single location can correspond with multiple entries, as indicated in the
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#Entries column in the Locations panel. Entry selections and selected locations can be synchronized in two
ways:

• Entries that correspond to selected locations can be selected in the database with Selection > Map to
database ( ). This action is particularly useful to check e.g. the position in a dendrogram of entries
that are originating from locations in close proximity. Note that a single selected location can give
rise to multiple selected entries.

• To show the locations of selected database entries in the Map panel and the Locations panel, use
Selection > Database to map ( ). This is a convenient action when one wants to check the geo-
graphical location of e.g. strains with highly similar patterns. Note that a location is selected as soon
as it contains a selected entry.

4.4 Exporting and printing

The geographical map can be printed directly to a printer using File > Print. The dialog box that appears is
the standard Windows Print dialog box, allowing you to choose a printer and change the properties.

The map can also be exported with File > Save as.

Figure 4.3: The Export image dialog box.

This dialog box allows you to export graphical information to a file or to the Windows clipboard in one of
several available formats. In case a file is exported, a file Name should always be entered or browsed for
via the <Browse> button. Exported files will open in their default editor. Information on the Windows
clipboard can be pasted into other applications. Following export options are available:

• PNG image (*.png): exports to a Portable Network Graphics (PNG) file. PNG is a raster graphics file
format that supports lossless data compression. A Name and Width (in pixels) should be specified;
the height will be determined automatically.

• JPG image (*.jpg): exports to a Joint Photographic Experts Group (JPEG) file. JPEG or JPG is a
raster graphics file format that uses a lossy data compression. A Name and Width (in pixels) should
be specified, as well as a Quality parameter. With the latter, a tradeoff can be obtained between storage
size and image quality.

• TIFF image (*.tiff): exports to a Tagged Image File Format (TIFF) file. TIFF is a raster graphics file
format with optional lossless data compression. A Name and Width (in pixels) should be specified.
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• Bitmap image (*.bmp): exports to a BMP bitmap image or device independent bitmap (DIB) file.
BMP is a raster graphics image file format used to store bitmap digital images, independently of the
display device. A Name and Width (in pixels) should be specified.

• PDF document (*.pdf): exports to a Portable Document Format (PDF) file. PDF is a file format
used to present documents in a manner independent of application software, hardware, and operating
systems. A Name and the Orientation (either Landscape or Portrait) should be specified.

• Postscript document (*.ps): exports to a PostScript (PS) file. PostScript is a computer language
for creating vector graphics. A Name and the Orientation (either Landscape or Portrait) should be
specified.

• SVG image (*.svg): exports to a Scalable Vector Graphics (SVG) file. SVG is an XML-based vector
image format for two-dimensional graphics. A Name should be specified.

• Metafile to clipboard: copies the graphics as Windows enhanced metafile to the clipboard. Enhanced
metafile is the standard clipboard exchange format between native Windows applications.

• Bitmap to clipboard: copies the graphics as a bitmap to the Windows clipboard. The Width (in pixels)
should be specified.
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